Compare commits
68 Commits
v2023.08.2
...
develop
Author | SHA1 | Date | |
---|---|---|---|
b3fba8f4ee | |||
e216c0ddbf | |||
ede2142b9f | |||
c9bedc3bf8 | |||
df8872064a | |||
af6c9cfbe6 | |||
73159308d1 | |||
158ef63f36 | |||
64ef4a1b5c | |||
70a31262ee | |||
eeecad130e | |||
7cd6626a64 | |||
ea9f7230ac | |||
4009da19cf | |||
83608ce85e | |||
922310c823 | |||
6ecdd2c54b | |||
57a40f12e3 | |||
642ed76421 | |||
91f34171b6 | |||
8529525524 | |||
c50babbc50 | |||
b5e7560c53 | |||
9f616e4dd9 | |||
8ca78641ff | |||
e2417fbdcc | |||
82fb14dc36 | |||
655ba28a6c | |||
c053c996d9 | |||
25917a63b9 | |||
53a55bbc48 | |||
cb184ccd4f | |||
5a9623f96f | |||
120da74f01 | |||
c6aa6a8089 | |||
2276e202d2 | |||
2caa7781e0 | |||
241b9ad3cc | |||
f7da4a3b74 | |||
f93a9cfaca | |||
acc3c13249 | |||
abd5cef671 | |||
b910fecb21 | |||
1ff432c20e | |||
ae5caf88d3 | |||
f165301856 | |||
50ce5a25ee | |||
b8a8c9257b | |||
7608a983e6 | |||
28c2bf152c | |||
707a8c6f30 | |||
4b5f2b63d0 | |||
ce0b211bfa | |||
0fbae8a5ca | |||
eaf60e139e | |||
c4d659a8fa | |||
8038eb5c97 | |||
b17355f36b | |||
7bfb1982b7 | |||
490b5558a7 | |||
ce8460a277 | |||
7a300bdbf0 | |||
86792b320e | |||
241d234ece | |||
e07c26e24d | |||
972aec6e6b | |||
f2d8692a4b | |||
b0e9d61731 |
14
Makefile
14
Makefile
@ -5,7 +5,7 @@ GIT_VERSION := $(shell git describe --always)
|
||||
DATE_VERSION := $(shell date +%Y.%m.%d)
|
||||
FULL_VERSION := v$(DATE_VERSION)-$(GIT_VERSION)
|
||||
|
||||
OPENWRT_VERSION ?= 22.03.2
|
||||
OPENWRT_VERSION ?= 23.05.2
|
||||
OPENWRT_TARGET ?= mvebu/cortexa9
|
||||
OPENWRT_TARGET_DASHED ?= $(shell echo $(OPENWRT_TARGET) | sed 's|/|-|')
|
||||
OPENWRT_PROFILE ?= linksys_wrt1200ac
|
||||
@ -15,8 +15,8 @@ BIN_DIR_NAME_SUFFIX ?=
|
||||
|
||||
IMAGEBUILDER_URL ?= https://downloads.openwrt.org/releases/$(OPENWRT_VERSION)/targets/$(OPENWRT_TARGET)/openwrt-imagebuilder-$(OPENWRT_VERSION)-$(OPENWRT_TARGET_DASHED).Linux-x86_64.tar.xz
|
||||
|
||||
IMAGEBUILDER_ARCHIVE_PATH := tmp/imagebuilder-$(OPENWRT_VERSION)-$(OPENWRT_TARGET_DASHED).tar.xz
|
||||
IMAGEBUILDER_DIR_PATH := $(PWD)/imagebuilder/$(OPENWRT_VERSION)/$(OPENWRT_TARGET)
|
||||
IMAGEBUILDER_ARCHIVE_PATH ?= tmp/imagebuilder-$(OPENWRT_VERSION)-$(OPENWRT_TARGET_DASHED).tar.xz
|
||||
IMAGEBUILDER_DIR_PATH ?= $(PWD)/imagebuilder/$(OPENWRT_VERSION)/$(OPENWRT_TARGET)
|
||||
IMAGEBUILDER_CUSTOM_PACKAGES_DIR_PATH := $(IMAGEBUILDER_DIR_PATH)/packages
|
||||
IMAGEBUILDER_CUSTOM_FILES_DIR_PATH := $(IMAGEBUILDER_DIR_PATH)/files
|
||||
|
||||
@ -28,7 +28,7 @@ EMISSARY_ARCH ?= armv6
|
||||
EMISSARY_RECONCILIATION_INTERVAL ?=
|
||||
EMISSARY_SERVER_URL ?=
|
||||
|
||||
BASE_INSTALL ?= install-emissary-files
|
||||
BASE_INSTALL ?= install-emissary-files install-common-uci-defaults install-common-additional-agent-collectors
|
||||
ADDITIONAL_INSTALL ?=
|
||||
ADDITIONAL_OPENWRT_PACKAGES ?=
|
||||
|
||||
@ -46,7 +46,7 @@ build: $(IMAGEBUILDER_DIR_PATH) $(IMAGEBUILDER_CUSTOM_PACKAGES_DIR_PATH) $(IMAGE
|
||||
|
||||
# Cleanup old packages signature
|
||||
rm -f $(IMAGEBUILDER_DIR_PATH)/Packages $(IMAGEBUILDER_DIR_PATH)/Packages.gz $(IMAGEBUILDER_DIR_PATH)/Packages.sig
|
||||
|
||||
|
||||
# Build firmware
|
||||
$(MAKE) \
|
||||
-C "$(IMAGEBUILDER_DIR_PATH)" \
|
||||
@ -56,6 +56,7 @@ build: $(IMAGEBUILDER_DIR_PATH) $(IMAGEBUILDER_CUSTOM_PACKAGES_DIR_PATH) $(IMAGE
|
||||
CONFIG_IPV6=n \
|
||||
FILES="$(IMAGEBUILDER_CUSTOM_FILES_DIR_PATH)" \
|
||||
BIN_DIR="$(BIN_DIR)" \
|
||||
ROOTFS_PARTSIZE="$(ROOTFS_PARTSIZE)" \
|
||||
clean image
|
||||
|
||||
$(IMAGEBUILDER_DIR_PATH): $(IMAGEBUILDER_ARCHIVE_PATH)
|
||||
@ -100,6 +101,7 @@ gitea-release: tools/gitea-release/bin/gitea-release.sh
|
||||
\( -name '*.img.gz' \
|
||||
-or -name '*.bin' \
|
||||
-or -name '*.img' \
|
||||
-or -name '*.itb' \
|
||||
\) -exec cp {} .gitea-release/ \;
|
||||
|
||||
GITEA_RELEASE_PROJECT="emissary-firmware" \
|
||||
@ -109,7 +111,7 @@ gitea-release: tools/gitea-release/bin/gitea-release.sh
|
||||
GITEA_RELEASE_NAME="$(FULL_VERSION)" \
|
||||
GITEA_RELEASE_COMMITISH_TARGET="$(GIT_VERSION)" \
|
||||
GITEA_RELEASE_IS_DRAFT="false" \
|
||||
GITEA_RELEASE_BODY="With Emissary $(EMISSARY_RELEASE)" \
|
||||
GITEA_RELEASE_BODY='Based on OpenWRT [`$(OPENWRT_VERSION)`](https://downloads.openwrt.org/releases/$(OPENWRT_VERSION)/targets/) and with Emissary [`$(EMISSARY_RELEASE)`](https://forge.cadoles.com/arcad/emissary/releases/tag/$(EMISSARY_RELEASE))' \
|
||||
GITEA_RELEASE_ATTACHMENTS="$$(find .gitea-release/* -type f)" \
|
||||
tools/gitea-release/bin/gitea-release.sh
|
||||
|
||||
|
@ -8,8 +8,13 @@ install/ # Tâches Make d'installation spécifiques aux différentes cibles d
|
||||
misc/ # Fichiers spécifiques aux différentes cibles de construction
|
||||
targets/ # Tâches Make de définition des différentes cibles de construction
|
||||
```
|
||||
|
||||
## Tutoriels
|
||||
|
||||
- [Premiers pas](./tutorials/first-steps.md)
|
||||
- [Compiler un firmware](./tutorials/firmware-compilation.md)
|
||||
- [Flasher une borne](./tutorials/device-flashing.md)
|
||||
- [Flasher une borne](./tutorials/device-flashing.md)
|
||||
|
||||
## Fiches matériel
|
||||
|
||||
- [Banana Pi](./hardware/bananapi.md)
|
||||
|
140
doc/hardware/bananapi.md
Normal file
140
doc/hardware/bananapi.md
Normal file
@ -0,0 +1,140 @@
|
||||
# BananaPi
|
||||
|
||||

|
||||
|
||||
## Caractéristiques
|
||||
|
||||
- MediaTek MT7986(Filogic 830) Quad core ARM Cortex A53
|
||||
- Wifi 6 2.4G/5G(MT7976C)
|
||||
- 2G DDR RAM
|
||||
- 8G eMMC flash
|
||||
- 128MB Nand flash
|
||||
- 2x 2.5GbE network port
|
||||
- 1x M.2 Key B USB inerface
|
||||
- 1x M.2 KEY M PCIe inerface
|
||||
- 1x USB2.0 interface
|
||||
- 1x Wan port (gigabit)
|
||||
- 4x LAN port (gigabit)
|
||||
|
||||
## Installation
|
||||
|
||||
Par défaut, la borne est livrée sans système d'exploitation, ce qui rend impossible la procédure de flashage conventionnelle.
|
||||
|
||||
BPI fournit un logiciel qui permet de prendre un fichier .img et de le mettre en place sur une carte SD.
|
||||
|
||||
### Installation bpi-tools
|
||||
|
||||
Il est recommandé d'installer préalablement pv pour plus de commodité. (Disponible et validé sur Ubuntu et Manjaro)
|
||||
|
||||
```Shell
|
||||
apt-get install pv
|
||||
```
|
||||
|
||||
Pour installer bpi-tools sur votre machine, si vous ne pouvez pas accéder à l'URL via curl, rendez-vous sur le dépôt de bpi-tools et effectuez le processus manuellement.
|
||||
|
||||
```Shell
|
||||
curl -sL https://github.com/BPI-SINOVOIP/bpi-tools/raw/master/bpi-tools | sudo -E bash
|
||||
```
|
||||
|
||||
### Installation firmware avec emissary
|
||||
|
||||
Dans cet exemple, nous partirons de l'image OpenWrt avec Emissary suivante : ```openwrt-22.03.2-emissary-v2023.08.02-bec8917-bcm27xx-bcm2711-rpi-4-squashfs-factory.img```
|
||||
|
||||
1. Téléchargement de l'image : Téléchargez l'image depuis la [forge cadoles](https://forge.cadoles.com/arcad/emissary-firmware/releases)
|
||||
Après le téléchargement, vous obtiendrez un fichier au format .gz.</br>
|
||||
2. Extraction : Exécutez la commande suivante pour extraire l'image (remplacez les ```**``` par les détails spécifiques du fichier) : ```gunzip openwrt-**-emissary-***-****-**-**-rpi-4-squashfs-factory.img.gz```
|
||||
3. Déplacement dans le dossier : Placez-vous dans le dossier contenant le fichier .img.
|
||||
4. Connexion de la carte SD : Branchez la carte SD sur votre machine. Pour vérifier l'identification de la carte, vous pouvez utiliser la commande ```dmesg``` et examiner les dernières lignes (généralement /dev/sda).
|
||||
5. Vérification du chemin d'accès : Confirmez le chemin d'accès à la carte SD (/dev/sd...).
|
||||
6. Copie sur la carte SD : Lancez la copie sur la carte SD en utilisant la commande bpi-copy (remplacez le nom de l'image et le chemin d'accès à la carte SD) :
|
||||
|
||||
```Shell
|
||||
sudo bpi-copy openwrt-22.03.2-emissary-v2023.08.02-bec8917-bcm27xx-bcm2711-rpi-4-squashfs-factory.img /dev/sda
|
||||
```
|
||||
|
||||
Le résultat ressemblera à ceci :
|
||||
|
||||
```Shell
|
||||
==============================================================
|
||||
jeu. 03 août 2023 10:09:12 CEST
|
||||
*** start COPY (blue led on ) .....
|
||||
umount device: /dev/sda
|
||||
umount /dev/sda1
|
||||
umount /dev/sda2
|
||||
==============================================================
|
||||
IMGFILE=openwrt-22.03.2-emissary-v2023.08.02-bec8917-bcm27xx-bcm2711-rpi-4-squashfs-factory.img
|
||||
==============================================================
|
||||
img
|
||||
8+1 enregistrements lus
|
||||
8+1 enregistrements écrits
|
||||
90475842 octets (90 MB, 86 MiB) copiés, 0,130052 s, 696 MB/s
|
||||
86,3MiO 0:00:00 [ 648MiO/s] [ <=> ]
|
||||
0+1381 enregistrements lus
|
||||
0+1381 enregistrements écrits
|
||||
*** end COPY (blue led off) .....
|
||||
jeu. 03 août 2023 10:09:18 CEST
|
||||
==============================================================
|
||||
RUNTIME 0:6
|
||||
OK!! You can remove the BOOTDISK /dev/sda now!!
|
||||
```
|
||||
|
||||
Une fois la copie terminée, retirez la carte SD. Vous pouvez maintenant l'insérer dans le boîtier de destination.
|
||||
|
||||
Après avoir flashé la carte, assurez-vous que les commutateurs sont correctement positionnés (sélection du boot), insérez la carte SD et branchez la borne.
|
||||
|
||||
Connectez-vous à un port LAN du boîtier qui distribuera une adresse IP via DHCP. Vous pourrez ensuite utiliser SSH pour y accéder.
|
||||
|
||||
### OS pour banana-bpi fournit par bpi
|
||||
|
||||
Pour installer OpenWrt sur le BPI-R3, vous devez d'abord télécharger l'image ```bananapi_bpi-r3-sdcard.img.gz``` fourni par OpenWrt. Vous pouvez le télécharger depuis leur [page de téléchargement](https://downloads.openwrt.org/snapshots/targets/mediatek/filogic/). Si vous ne trouvez pas le fichier directement, suivez ces indications :
|
||||
|
||||
1. Accédez à la page de téléchargement OpenWrt (cf image suivante).
|
||||
2. Recherchez le dossier correspondant au modèle de votre matériel, dans ce cas bananapi_bpi-r3.
|
||||
3. Téléchargez le fichier bananapi_bpi-r3-sdcard.img.gz.
|
||||
|
||||

|
||||
|
||||
Après avoir téléchargé le fichier, vous pouvez continuer avec les étapes d'installation.
|
||||
|
||||
#### Flash du Firmware OpenWrt pour BPI
|
||||
|
||||
Suivez les étapes ci-dessous pour flasher la carte avec le firmware OpenWrt pour BPI :
|
||||
|
||||
1. Téléchargement de l'image : Si vous avez suivi les instructions précédentes, vous devriez avoir l'image de l'OS.
|
||||
2. Extraction de l'image : Exécutez la commande suivante pour extraire l'image (remplacez les **** par les détails spécifiques du fichier) : ```gunzip bananapi_****.img.gz```
|
||||
3. Placement de l'image : Placez-vous dans le dossier contenant le fichier .img.
|
||||
4. Branchement de la carte SD : Branchez la carte SD sur votre machine. Pour vérifier son identification, utilisez ```dmesg``` et observez les dernières lignes (généralement sda).
|
||||
5. Copie sur la carte SD : Lancez la copie sur la carte SD en utilisant la commande bpi-copy (remplacez les détails de l'image et le chemin d'accès à la carte SD) :
|
||||
|
||||
```Shell
|
||||
sudo bpi-copy bananapi_bpi-r3-sdcard.img /dev/sda
|
||||
```
|
||||
|
||||
Une fois la carte flashée, assurez-vous que le switch a tous ses jumpers orientés vers le haut (sélection du boot). Insérez ensuite la carte SD et branchez la borne.
|
||||
|
||||
Assurez-vous que votre carte réseau est configurée comme suit :
|
||||
|
||||
- Réseau : 192.168.1.0/24
|
||||
- Passerelle : 192.168.1.1
|
||||
|
||||
Brancher votre câble RJ45 sur le port VLAN1, et connectez vous en ssh.(temps de boot moins de 30 secondes)
|
||||
|
||||
```Shell
|
||||
ssh root@192.168.1.1
|
||||
```
|
||||
|
||||
Pour la première connexion, aucun mot de passe n'est requis.
|
||||
|
||||
## FAQ
|
||||
|
||||
### Sélection du Système de Boot
|
||||
|
||||
Pour choisir le système de boot, il suffit de manipuler un switch composé de quatre jumpers. Par défaut, ils sont tous en position haute, ce qui configure le démarrage à partir de la carte microSD.
|
||||
|
||||

|
||||
|
||||
### Noms des Périphériques Réseau
|
||||
|
||||
Par défaut, les périphériques réseau sont disposés et nommés comme suit :
|
||||
|
||||

|
BIN
doc/img/bpi-r3-case.jpg
Normal file
BIN
doc/img/bpi-r3-case.jpg
Normal file
Binary file not shown.
After Width: | Height: | Size: 162 KiB |
BIN
doc/img/bpi-r3-download.png
Normal file
BIN
doc/img/bpi-r3-download.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 13 KiB |
BIN
doc/img/bpi-r3-lan-pic.jpg
Normal file
BIN
doc/img/bpi-r3-lan-pic.jpg
Normal file
Binary file not shown.
After Width: | Height: | Size: 36 KiB |
BIN
doc/img/bpi-r3-switch.png
Normal file
BIN
doc/img/bpi-r3-switch.png
Normal file
Binary file not shown.
After Width: | Height: | Size: 18 KiB |
@ -21,6 +21,7 @@ make linksys-wrt1900ac
|
||||
# ... ou pour le routeur Linksys WRT3200ACM
|
||||
make linksys-wrt3200acm
|
||||
```
|
||||
|
||||
## Créer une nouvelle cible de construction
|
||||
|
||||
Dans ce tutoriel, nous allons voir comment créer une nouvelle cible de construction pour un nouvel appareil, ici un [Banana Pi R3](https://wiki.banana-pi.org/Banana_Pi_BPI-R3).
|
||||
@ -54,7 +55,7 @@ Dans ce tutoriel, nous allons voir comment créer une nouvelle cible de construc
|
||||
```
|
||||
|
||||
**Explication des variables**
|
||||
|
||||
|
||||
- `OPENWRT_VERSION`: Version d'OpenWRT à utiliser. _Normalement prédéfinie par le fichier `Makefile` principal mais ill est ici nécessaire de surcharger la variable car il n'existe à ce jour pas de version stable d'OpenWRT pour la BananaPi R3._
|
||||
- `IMAGEBUILDER_URL`: URL à utiliser pour télécharger le "builder" OpenWRT. _Normalement prédéfinie par le fichier `Makefile` principal mais ill est ici nécessaire de surcharger la variable car il n'existe à ce jour pas de version stable d'OpenWRT pour la BananaPi R3._
|
||||
- `ADDITIONAL_INSTALL`: Tâches Make d'installation supplémentaires à exécuter. Voir section suivante.
|
||||
@ -62,13 +63,21 @@ Dans ce tutoriel, nous allons voir comment créer une nouvelle cible de construc
|
||||
- `EMISSARY_ARCH`: Architecture du binaire Emissary à déployer dans le firmware
|
||||
- `OPENWRT_PROFILE`: "Profil" OpenWRT associé à l'appareil
|
||||
|
||||
3. Lancer la compilation du firmware
|
||||
3. Préparation.
|
||||
|
||||
Lancer la commande suivante pour télécharger (ou mettre à jours) les fichiers tar.gz nécessaire à la construction du firmware. Si cette commande n'a pas été exécutée au moins une fois, vous ne serez pas en mesure de construire le ou les firmwares nécessaires.
|
||||
|
||||
```shell
|
||||
make download-emissary-release
|
||||
```
|
||||
|
||||
4. Lancer la compilation du firmware
|
||||
|
||||
```shell
|
||||
make bpi-r3
|
||||
```
|
||||
|
||||
Les fichiers du firmware seront générés dans le répertoire `bin/snapshot/mediatek/filogic/bananapi_bpi-r3/`
|
||||
Les fichiers du firmware seront générés dans le répertoire `depot/bin/snapshot/mediatek/filogic/bananapi_bpi-r3/`
|
||||
|
||||
> 🛈 **Comment trouver les valeurs des variables `OPENWRT_TARGET` et `OPENWRT_PROFILE` ?**
|
||||
>
|
||||
|
@ -1 +1 @@
|
||||
2023.8.25-stable.1802.612f18a
|
||||
2024.3.13-stable.821.cec5c78
|
||||
|
3
install/bananapi.mk
Normal file
3
install/bananapi.mk
Normal file
@ -0,0 +1,3 @@
|
||||
install-bpi-r3-network-config:
|
||||
mkdir -p files/etc/config
|
||||
cp misc/bpi-r3/uci/network files/etc/config/network
|
6
install/common.mk
Normal file
6
install/common.mk
Normal file
@ -0,0 +1,6 @@
|
||||
install-common-uci-defaults:
|
||||
mkdir -p files/etc/uci-defaults
|
||||
cp misc/common/uci-defaults/* files/etc/uci-defaults/
|
||||
|
||||
install-common-additional-agent-collectors: tools/yq/bin/yq
|
||||
tools/yq/bin/yq -i '.agent.collectors += load("misc/common/agent/collectors.yml")' files/etc/emissary/agent.yml
|
@ -31,6 +31,10 @@ install-emissary-files: tools/yq/bin/yq tools/upx/bin/upx
|
||||
tools/yq/bin/yq -i '.agent.controllers.sysupgrade.firmwareVersionCommand = ["sh", "-c", "source /etc/emissary_firmware && echo \"$$FIRMWARE_VERSION\""]' files/etc/emissary/agent.yml
|
||||
tools/yq/bin/yq -i '.agent.controllers.app.dataDir = "/data/emissary/apps/data"' files/etc/emissary/agent.yml
|
||||
tools/yq/bin/yq -i '.agent.controllers.app.downloadDir = "/data/emissary/apps/bundles"' files/etc/emissary/agent.yml
|
||||
tools/yq/bin/yq -i '.sentry.dsn = "$${EMISSARY_SENTRY_DSN}"' files/etc/emissary/agent.yml
|
||||
tools/yq/bin/yq -i '.sentry.environment = "$${EMISSARY_SENTRY_ENVIRONMENT}"' files/etc/emissary/agent.yml
|
||||
tools/yq/bin/yq -i '.agent.controllers.status.claimURL = "$${EMISSARY_CONTROLLERS_STATUS_CLAIM_URL}"' files/etc/emissary/agent.yml
|
||||
tools/yq/bin/yq -i '.agent.controllers.status.agentURL = "$${EMISSARY_CONTROLLERS_STATUS_AGENT_URL}"' files/etc/emissary/agent.yml
|
||||
|
||||
# Copy emissary binary
|
||||
mkdir -p files/usr/local/bin
|
||||
|
@ -1,7 +1,3 @@
|
||||
install-rpi-network-config:
|
||||
mkdir -p files/etc/config
|
||||
cp misc/rpi/uci/network files/etc/config/network
|
||||
|
||||
install-rpi-uci-defaults:
|
||||
mkdir -p files/etc/uci-defaults
|
||||
cp misc/rpi/uci-defaults/* files/etc/uci-defaults/
|
||||
cp misc/rpi/uci/network files/etc/config/network
|
24
misc/bpi-r3/uci/network
Normal file
24
misc/bpi-r3/uci/network
Normal file
@ -0,0 +1,24 @@
|
||||
config interface 'lan'
|
||||
option type 'bridge'
|
||||
option proto 'static'
|
||||
option ipaddr '192.168.1.1'
|
||||
option netmask '255.255.255.0'
|
||||
list ports 'lan1'
|
||||
list ports 'lan2'
|
||||
list ports 'lan3'
|
||||
list ports 'lan4'
|
||||
list ports 'sfp2'
|
||||
option ip6assign '60'
|
||||
|
||||
config interface 'wan'
|
||||
option type 'bridge'
|
||||
list ports 'eth1'
|
||||
list ports 'wan'
|
||||
option proto 'dhcp'
|
||||
|
||||
config device
|
||||
config interface 'loopback'
|
||||
option device 'lo'
|
||||
option proto 'static'
|
||||
option ipaddr '127.0.0.1'
|
||||
option netmask '255.0.0.0'
|
9
misc/common/agent/collectors.yml
Normal file
9
misc/common/agent/collectors.yml
Normal file
@ -0,0 +1,9 @@
|
||||
- name: network-interfaces
|
||||
command: ip
|
||||
args:
|
||||
- addr
|
||||
- show
|
||||
- name: emissary-firmware
|
||||
command: cat
|
||||
args:
|
||||
- /etc/emissary_firmware
|
@ -0,0 +1,79 @@
|
||||
#!/bin/sh
|
||||
|
||||
MIN_DISK_SPACE_MB=1000
|
||||
|
||||
list_disks() {
|
||||
lsblk -o NAME -r -d -n
|
||||
}
|
||||
|
||||
main() {
|
||||
local disks=$(list_disks)
|
||||
|
||||
local found_free_space=0
|
||||
local found_device=""
|
||||
|
||||
for device_name in ${disks}; do
|
||||
local device="/dev/${device_name}"
|
||||
echo "Checking disk '$device'..."
|
||||
|
||||
local disk_free_space="$(parted $device unit MB print free 2>/dev/null | grep 'Free Space' | tail -n1 | awk '{ print $3 }')"
|
||||
disk_free_space=${disk_free_space%MB}
|
||||
disk_free_space=$(printf '%.0f' "${disk_free_space:-0}")
|
||||
|
||||
echo "Free space on disk: ${disk_free_space}"
|
||||
|
||||
if [ ! -z "${disk_free_space}" ]; then
|
||||
if [ ${disk_free_space} -gt ${found_free_space} ]; then
|
||||
found_free_space=${disk_free_space}
|
||||
found_device=${device}
|
||||
fi
|
||||
fi
|
||||
done
|
||||
|
||||
if [ -z "${found_device}" ] || [ ${MIN_DISK_SPACE_MB} -gt ${found_free_space} ]; then
|
||||
echo "No device with sufficient remaining disk space, exiting."
|
||||
exit 1
|
||||
fi
|
||||
|
||||
echo "Creating new partition on '${found_device}' with remaining disk free space"
|
||||
|
||||
local last_partition_end_mb=$(parted "$found_device" unit MB print | awk '/^ [0-9]+ / {start=$3} END {print int(start)}')
|
||||
|
||||
if [ "${last_partition_end_mb}" != "0" ]; then
|
||||
parted -s "${found_device}" -f -a opt mkpart primary "${last_partition_end_mb}MB" '100%'
|
||||
else
|
||||
parted -s "${found_device}" -f -a opt mkpart primary '0%' '100%'
|
||||
fi
|
||||
|
||||
sync
|
||||
|
||||
local last_partition_number=$(parted ${found_device} print | grep -o -e '^ [0-9]*' | awk '{print $1}' | tail -n 1)
|
||||
local new_partition_device=$(lsblk -r -n -o PARTN,NAME ${found_device} | awk -v partition_number="${last_partition_number}" '$1 == partition_number {print $2}')
|
||||
|
||||
mkfs.ext4 -F /dev/${new_partition_device}
|
||||
if [ $? -ne 0 ]; then
|
||||
echo "Could not initialize filesystem on new partition !"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
local new_partition_uuid=$(lsblk -r -n -o PARTN,UUID ${found_device} | awk -v partition_number="${last_partition_number}" '$1 == partition_number {print $2}')
|
||||
|
||||
if [ -z "${new_partition_uuid}" ]; then
|
||||
echo "Could not find partition with number '${last_partition_number}' !"
|
||||
exit 1
|
||||
fi
|
||||
|
||||
umount -f /data
|
||||
rm -rf /data
|
||||
mkdir -p /data
|
||||
|
||||
uci add fstab mount
|
||||
uci set fstab.@mount[-1].target='/data'
|
||||
uci set fstab.@mount[-1].uuid=${new_partition_uuid}
|
||||
uci set fstab.@mount[-1].enabled='1'
|
||||
uci commit fstab
|
||||
|
||||
reload_config
|
||||
}
|
||||
|
||||
main
|
@ -2,4 +2,8 @@ package emissary
|
||||
|
||||
config main 'agent'
|
||||
option reconciliation_interval '60'
|
||||
option server_url 'https://emissary.cadol.es'
|
||||
option server_url 'https://emissary.cadol.es'
|
||||
option claim_url 'https://emissary.cadol.es/hq/claim/%v'
|
||||
option agent_url 'https://emissary.cadol.es/hq/agents/%v'
|
||||
option sentry_dsn ''
|
||||
option sentry_environment ''
|
@ -1,26 +1,30 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
|
||||
USE_PROCD=1
|
||||
START=50
|
||||
START=99
|
||||
STOP=50
|
||||
|
||||
start_service() {
|
||||
config_load emissary
|
||||
|
||||
mkdir -p /usr/share/emissary
|
||||
mkdir -p /var/lib/emissary
|
||||
mkdir -p /data/emissary
|
||||
|
||||
config_get emissary_reconciliation_interval agent 'reconciliation_interval' "60"
|
||||
config_get emissary_server_url agent 'server_url' "https://emissary.cadol.es"
|
||||
config_get emissary_agent_claim_url agent 'claim_url' "https://emissary.cadol.es/hq/claim/%v"
|
||||
config_get emissary_agent_url agent 'agent_url' "https://emissary.cadol.es/hq/agents/%v"
|
||||
config_get emissary_sentry_dsn agent 'sentry_dsn' ""
|
||||
config_get emissary_sentry_environment agent 'sentry_environment' ""
|
||||
|
||||
local config_file="/etc/emissary/agent.yml"
|
||||
procd_open_instance emissary-agent
|
||||
procd_set_param env EMISSARY_SERVER_URL="$emissary_server_url" EMISSARY_RECONCILIATION_INTERVAL="$emissary_reconciliation_interval"
|
||||
procd_set_param env EMISSARY_SERVER_URL="$emissary_server_url" EMISSARY_RECONCILIATION_INTERVAL="$emissary_reconciliation_interval" EMISSARY_SENTRY_DSN="$emissary_sentry_dsn" EMISSARY_SENTRY_ENVIRONMENT="$emissary_sentry_environment" EMISSARY_CONTROLLERS_STATUS_CLAIM_URL="$emissary_agent_claim_url" EMISSARY_CONTROLLERS_STATUS_AGENT_URL="$emissary_agent_url"
|
||||
procd_set_param command /usr/local/bin/emissary
|
||||
procd_append_param command --workdir /usr/share/emissary
|
||||
procd_append_param command --config "$config_file"
|
||||
procd_append_param command agent run
|
||||
procd_set_param respawn ${respawn_threshold:-3600} ${respawn_timeout:-5} ${respawn_retry:-5}
|
||||
procd_set_param respawn ${respawn_threshold:-3600} ${respawn_timeout:-5} ${respawn_retry:-17280}
|
||||
procd_set_param file "$config_file"
|
||||
procd_set_param stdout 1
|
||||
procd_set_param stderr 1
|
||||
|
@ -17,6 +17,12 @@ main() {
|
||||
if [ ! -z "${EMISSARY_SERVER_URL}" ]; then
|
||||
uci set "emissary.agent.server_url=${EMISSARY_SERVER_URL}"
|
||||
fi
|
||||
if [ ! -z "${EMISSARY_SENTRY_DSN}" ]; then
|
||||
uci set "emissary.agent.sentry_dsn=${EMISSARY_SENTRY_DSN}"
|
||||
fi
|
||||
if [ ! -z "${EMISSARY_SENTRY_ENVIRONMENT}" ]; then
|
||||
uci set "emissary.agent.sentry_environment=${EMISSARY_SENTRY_ENVIRONMENT}"
|
||||
fi
|
||||
|
||||
# Commit modifications
|
||||
uci commit
|
||||
|
@ -8,7 +8,7 @@ ARG https_proxy=
|
||||
# Install dev environment dependencies
|
||||
RUN export DEBIAN_FRONTEND=noninteractive &&\
|
||||
apt-get update -y &&\
|
||||
apt-get install -y --no-install-recommends curl ca-certificates build-essential wget unzip tar git jq gawk python3 rsync file
|
||||
apt-get install -y --no-install-recommends curl ca-certificates build-essential wget unzip tar git jq gawk python3 rsync file python3-distutils
|
||||
|
||||
# Add LetsEncrypt certificates
|
||||
RUN curl -k https://forge.cadoles.com/Cadoles/Jenkins/raw/branch/master/resources/com/cadoles/common/add-letsencrypt-ca.sh | bash
|
@ -1,37 +0,0 @@
|
||||
#/bin/sh
|
||||
|
||||
set -e
|
||||
|
||||
main() {
|
||||
# Update default firewall ruleset
|
||||
uci add firewall rule
|
||||
uci set firewall.@rule[-1].name='Allow SSH on WAN'
|
||||
uci set firewall.@rule[-1].src='wan'
|
||||
uci set firewall.@rule[-1].proto='tcp'
|
||||
uci set firewall.@rule[-1].dest_port='22'
|
||||
uci set firewall.@rule[-1].target='ACCEPT'
|
||||
|
||||
uci add firewall rule
|
||||
uci set firewall.@rule[-1].name='Allow HTTP on WAN'
|
||||
uci set firewall.@rule[-1].src='wan'
|
||||
uci set firewall.@rule[-1].proto='tcp'
|
||||
uci set firewall.@rule[-1].dest_port='80'
|
||||
uci set firewall.@rule[-1].target='ACCEPT'
|
||||
|
||||
uci add firewall rule
|
||||
uci set firewall.@rule[-1].name='Allow HTTPS on WAN'
|
||||
uci set firewall.@rule[-1].src='wan'
|
||||
uci set firewall.@rule[-1].proto='tcp'
|
||||
uci set firewall.@rule[-1].dest_port='443'
|
||||
uci set firewall.@rule[-1].target='ACCEPT'
|
||||
|
||||
uci commit firewall
|
||||
|
||||
# Disable DNS-rebind protection
|
||||
uci set dhcp.@dnsmasq[0].rebind_protection='0'
|
||||
uci commit dhcp
|
||||
|
||||
reload_config
|
||||
}
|
||||
|
||||
main
|
@ -11,14 +11,13 @@ main() {
|
||||
fi
|
||||
|
||||
# Accumulate data to create unique machine id
|
||||
local mac_addresses=$(cat /sys/class/net/*/address | uniq | sort)
|
||||
local device_uuid=$(dmidecode | grep UUID)
|
||||
local random_uuid=$(cat /proc/sys/kernel/random/uuid)
|
||||
|
||||
# Ensure destination directory
|
||||
mkdir -p "$(dirname "$machine_id_file")"
|
||||
|
||||
# Generate SHA256 hash of data and save it to $machine_id_file
|
||||
echo "$mac_adresses $device_uuid" | sha256sum | cut -d ' ' -f1 > "$machine_id_file"
|
||||
echo "$random_uuid" | sha256sum | cut -d ' ' -f1 > "$machine_id_file"
|
||||
}
|
||||
|
||||
main
|
@ -1,37 +0,0 @@
|
||||
#/bin/sh
|
||||
|
||||
set -e
|
||||
|
||||
main() {
|
||||
# Update default firewall ruleset
|
||||
uci add firewall rule
|
||||
uci set firewall.@rule[-1].name='Allow SSH on WAN'
|
||||
uci set firewall.@rule[-1].src='wan'
|
||||
uci set firewall.@rule[-1].proto='tcp'
|
||||
uci set firewall.@rule[-1].dest_port='22'
|
||||
uci set firewall.@rule[-1].target='ACCEPT'
|
||||
|
||||
uci add firewall rule
|
||||
uci set firewall.@rule[-1].name='Allow HTTP on WAN'
|
||||
uci set firewall.@rule[-1].src='wan'
|
||||
uci set firewall.@rule[-1].proto='tcp'
|
||||
uci set firewall.@rule[-1].dest_port='80'
|
||||
uci set firewall.@rule[-1].target='ACCEPT'
|
||||
|
||||
uci add firewall rule
|
||||
uci set firewall.@rule[-1].name='Allow HTTPS on WAN'
|
||||
uci set firewall.@rule[-1].src='wan'
|
||||
uci set firewall.@rule[-1].proto='tcp'
|
||||
uci set firewall.@rule[-1].dest_port='443'
|
||||
uci set firewall.@rule[-1].target='ACCEPT'
|
||||
|
||||
uci commit firewall
|
||||
|
||||
# Disable DNS-rebind protection
|
||||
uci set dhcp.@dnsmasq[0].rebind_protection='0'
|
||||
uci commit dhcp
|
||||
|
||||
reload_config
|
||||
}
|
||||
|
||||
main
|
@ -1,3 +1,8 @@
|
||||
luci
|
||||
openssh-server
|
||||
openssh-sftp-server
|
||||
openssh-sftp-server
|
||||
parted
|
||||
lsblk
|
||||
e2fsprogs
|
||||
block-mount
|
||||
kmod-fs-ext4
|
10
targets/bananapi.mk
Normal file
10
targets/bananapi.mk
Normal file
@ -0,0 +1,10 @@
|
||||
all: bpi-r3
|
||||
|
||||
bpi-r3:
|
||||
$(MAKE) \
|
||||
ADDITIONAL_INSTALL="install-bpi-r3-network-config" \
|
||||
ADDITIONAL_OPENWRT_PACKAGES="block-mount kmod-fs-ext4 kmod-usb-storage kmod-usb2" \
|
||||
OPENWRT_TARGET="mediatek/filogic" \
|
||||
EMISSARY_ARCH="arm64" \
|
||||
OPENWRT_PROFILE="bananapi_bpi-r3" \
|
||||
build
|
@ -2,7 +2,7 @@ all: x86-generic
|
||||
|
||||
x86-generic:
|
||||
$(MAKE) \
|
||||
ADDITIONAL_INSTALL="install-x86-network-config install-x86-uci-defaults" \
|
||||
ADDITIONAL_INSTALL="install-x86-network-config" \
|
||||
ADDITIONAL_OPENWRT_PACKAGES="dmidecode" \
|
||||
OPENWRT_TARGET="x86/generic" \
|
||||
EMISSARY_ARCH="386" \
|
||||
|
@ -2,7 +2,7 @@ all: rpi-4 rpi-3
|
||||
|
||||
rpi-4:
|
||||
$(MAKE) \
|
||||
ADDITIONAL_INSTALL="install-rpi-network-config install-rpi-uci-defaults" \
|
||||
ADDITIONAL_INSTALL="install-rpi-network-config" \
|
||||
OPENWRT_TARGET="bcm27xx/bcm2711" \
|
||||
EMISSARY_ARCH="arm64" \
|
||||
OPENWRT_PROFILE="rpi-4" \
|
||||
@ -10,7 +10,7 @@ rpi-4:
|
||||
|
||||
rpi-3:
|
||||
$(MAKE) \
|
||||
ADDITIONAL_INSTALL="install-rpi-network-config install-rpi-uci-defaults" \
|
||||
ADDITIONAL_INSTALL="install-rpi-network-config" \
|
||||
OPENWRT_TARGET="bcm27xx/bcm2710" \
|
||||
EMISSARY_ARCH="arm64" \
|
||||
OPENWRT_PROFILE="rpi-3" \
|
||||
|
Loading…
x
Reference in New Issue
Block a user