bananapi-r3 #2

Merged
wpetit merged 10 commits from bananapi-r3 into master 2023-08-30 18:03:39 +02:00
6 changed files with 141 additions and 6 deletions
Showing only changes of commit 972aec6e6b - Show all commits

5
install/bananapi.mk Normal file
View File

@ -0,0 +1,5 @@
install-bpi-r3-network-config:
mkdir -p files/etc/config
cp misc/bpi-r3/uci/network files/etc/config/network
cp misc/bpi-r3/uci/wireless files/etc/config/wireless
cp misc/bpi-r3/uci/system files/etc/config/system

47
misc/bpi-r3/uci/network Normal file
View File

@ -0,0 +1,47 @@
config device
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
wpetit marked this conversation as resolved Outdated

La configuration ne devrait contenir que le minimum vital pour que la configuration réseau soit fonctionnelle (i.e. interface WAN en mode DHCP).

On ne devrait pas surcharger les autres propriétés de la configuration UCI et maintenir celles par défaut fournies par le firmware OpenWRT.

i.e. supprimer le bloc globals si possible.

La configuration ne devrait contenir que le minimum vital pour que la configuration réseau soit fonctionnelle (i.e. interface WAN en mode DHCP). On ne devrait pas surcharger les autres propriétés de la configuration UCI et maintenir celles par défaut fournies par le firmware OpenWRT. i.e. supprimer le bloc `globals` si possible.
option ula_prefix 'fd78:1aa3:8b15::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'sfp2'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'br-wan'
option type 'bridge'
list ports 'eth1'
list ports 'wan'
config device
option name 'eth1'
option macaddr '96:37:22:3f:67:af'
wpetit marked this conversation as resolved Outdated

On ne devrait pas fixer l'adresse MAC des cartes réseaux.

On ne devrait pas fixer l'adresse MAC des cartes réseaux.
config device
option name 'wan'
option macaddr '96:37:22:3f:67:af'
wpetit marked this conversation as resolved Outdated

On ne devrait pas fixer l'adresse MAC des cartes réseaux.

On ne devrait pas fixer l'adresse MAC des cartes réseaux.
config interface 'wan'
option device 'br-wan'
option proto 'dhcp'
config interface 'wan6'
option device 'br-wan'
option proto 'dhcpv6'

15
misc/bpi-r3/uci/system Normal file
View File

@ -0,0 +1,15 @@
config system
wpetit marked this conversation as resolved Outdated

Je ne pense pas qu'il soit nécessaire de surcharger cette partie de la configuration de la BananaPi pour que le firmware fonctionne.

Je ne pense pas qu'il soit nécessaire de surcharger cette partie de la configuration de la BananaPi pour que le firmware fonctionne.
option hostname 'OpenWrt'
option timezone 'UTC'
option ttylogin '0'
option log_size '64'
option urandom_seed '0'
option compat_version '1.1'
config timeserver 'ntp'
option enabled '1'
option enable_server '0'
list server '0.openwrt.pool.ntp.org'
list server '1.openwrt.pool.ntp.org'
list server '2.openwrt.pool.ntp.org'
list server '3.openwrt.pool.ntp.org'

29
misc/bpi-r3/uci/wireless Normal file
View File

@ -0,0 +1,29 @@
config wifi-device 'radio0'
wpetit marked this conversation as resolved Outdated

Je pense qu'il n'est pas nécessaire de surcharger cette partie de la configuration UCI. La configuration des cartes WiFi doit être intégrée dans le firmware OpenWRT de base.

Je pense qu'il n'est pas nécessaire de surcharger cette partie de la configuration UCI. La configuration des cartes WiFi doit être intégrée dans le firmware OpenWRT de base.
option type 'mac80211'
option path 'platform/soc/18000000.wifi'
option channel '1'
option band '2g'
option htmode 'HE20'
option disabled '1'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc/18000000.wifi+1'
option channel '36'
option band '5g'
option htmode 'HE80'
option disabled '1'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'

View File

@ -1,9 +1,47 @@
config interface 'loopback' config device
option ifname 'lo' config interface 'loopback'
option device 'lo'
option proto 'static' option proto 'static'
option ipaddr '127.0.0.1' option ipaddr '127.0.0.1'
option netmask '255.0.0.0' option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd78:1aa3:8b15::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'sfp2'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'br-wan'
option type 'bridge'
list ports 'eth1'
list ports 'wan'
config device
option name 'eth1'
option macaddr '96:37:22:3f:67:af'
config device
option name 'wan'
option macaddr '96:37:22:3f:67:af'
config interface 'wan' config interface 'wan'
option ifname 'eth0' option device 'br-wan'
option proto 'dhcp' option proto 'dhcp'
config interface 'wan6'
option device 'br-wan'
option proto 'dhcpv6'

View File

@ -4,8 +4,9 @@ bpi-r3:
$(MAKE) \ $(MAKE) \
OPENWRT_VERSION="snapshot" \ OPENWRT_VERSION="snapshot" \
IMAGEBUILDER_URL=https://downloads.openwrt.org/snapshots/targets/mediatek/filogic/openwrt-imagebuilder-mediatek-filogic.Linux-x86_64.tar.xz \ IMAGEBUILDER_URL=https://downloads.openwrt.org/snapshots/targets/mediatek/filogic/openwrt-imagebuilder-mediatek-filogic.Linux-x86_64.tar.xz \
ADDITIONAL_INSTALL="" \ ADDITIONAL_INSTALL="install-bpi-r3-network-config" \
ADDITIONAL_OPENWRT_PACKAGES="block-mount kmod-fs-ext4 kmod-usb-storage kmod-usb2" \
OPENWRT_TARGET="mediatek/filogic" \ OPENWRT_TARGET="mediatek/filogic" \
EMISSARY_ARCH="arm64" \ EMISSARY_ARCH="arm64" \
OPENWRT_PROFILE="bananapi_bpi-r3" \ OPENWRT_PROFILE="bananapi_bpi-r3" \
build build