You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 
Emmanuel Garette bb5b32a435 add OpenSSH plugin 4 months ago
.github Merge branch 'master' into enable-codeql-scanning 6 months ago
docker multiple fixes docker alpine build 8 months ago
docs add OpenSSH plugin 4 months ago
gulp (node:73186) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead. 6 months ago
lemur add OpenSSH plugin 4 months ago
trustores initial commit 6 years ago
.bowerrc Revert "Precommit - Fix linty things" 3 years ago
.coveragerc Removing tests folder from coverage report. (#788) 4 years ago
.gitattributes adding automatic versioning 5 years ago
.gitignore Remove celerybear-schedule 7 months ago
.jshintignore Pleasing the JSHint gods 6 years ago
.jshintrc Revert "Precommit - Fix linty things" 3 years ago
.pre-commit-config.yaml Add bandit to test and pre-commit 2 years ago
.readthedocs.yml Fix docs and enable fail on warning 7 months ago
.travis.yml add make test-js, minor modification in gulp build 8 months ago
AUTHORS Version bump and needed documentation. 6 years ago
CHANGELOG.rst release 0.9.0 6 months ago
Dockerfile fixing Dockerfile, Lemur builds now 1 year ago
LICENSE Addressing comments. Updating copyrights. Added function to determine authorative name server 3 years ago
MANIFEST.in add missing requirements files for setup 3 years ago
Makefile Use --no-emit-index-url instead of deprecated --no-index in pip-compile 9 months ago
OSSMETADATA adding OSSMETADATA for NetflixOSS tracking 5 years ago
README.rst Update README.rst 1 year ago
bower.json lodash upgrade 4.17.20 9 months ago
config-default.py initial commit 6 years ago
docker-compose.yml Update requirements - upgrade to py37 2 years ago
gulpfile.js Pleasing the PEP8 gods 6 years ago
package.json add make test-js, minor modification in gulp build 8 months ago
requirements-dev.in flake8 version 3.8.4 10 months ago
requirements-dev.txt Bump pre-commit from 2.11.0 to 2.11.1 6 months ago
requirements-docs.in Add missing dependency 6 months ago
requirements-docs.txt Bump boto3 from 1.17.22 to 1.17.27 6 months ago
requirements-tests.in adding cert 6 months ago
requirements-tests.txt Bump boto3 from 1.17.22 to 1.17.27 6 months ago
requirements.in adding cert 6 months ago
requirements.txt Bump boto3 from 1.17.22 to 1.17.27 6 months ago
setup.cfg Ensuring that acme and cryptography respect different key types (#554) 4 years ago
setup.py add OpenSSH plugin 4 months ago
tox.ini add make test-build-js 8 months ago

README.rst

Lemur
=====

.. image:: https://badges.gitter.im/Join%20Chat.svg
:alt: Join the chat at https://gitter.im/Netflix/lemur
:target: https://gitter.im/Netflix/lemur?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge

.. image:: https://readthedocs.org/projects/lemur/badge/?version=latest
:target: https://lemur.readthedocs.io
:alt: Latest Docs

.. image:: https://img.shields.io/badge/NetflixOSS-active-brightgreen.svg

.. image:: https://travis-ci.org/Netflix/lemur.svg
:target: https://travis-ci.org/Netflix/lemur

.. image:: https://coveralls.io/repos/github/Netflix/lemur/badge.svg?branch=master
:target: https://coveralls.io/github/Netflix/lemur?branch=master



Lemur manages TLS certificate creation. While not able to issue certificates itself, Lemur acts as a broker between CAs
and environments providing a central portal for developers to issue TLS certificates with 'sane' defaults.

It works on Python 3.7. We deploy on Ubuntu and develop on OS X.


Project resources
=================

- `Lemur Blog Post <http://techblog.netflix.com/2015/09/introducing-lemur.html>`_
- `Documentation <http://lemur.readthedocs.io/>`_
- `Source code <https://github.com/netflix/lemur>`_
- `Issue tracker <https://github.com/netflix/lemur/issues>`_
- `Docker <https://github.com/Netflix/lemur-docker>`_