Update Dockerfile.patch to work with new 1.13.0 update (#7)
* Fix Dockerfile.patch to work with new 1.13.0 update * Fix control file for 1.13.0 release
This commit is contained in:
parent
9b87666c87
commit
ca53b2fe5c
@ -1,13 +1,6 @@
|
|||||||
--- ./git/docker/amd64/sqlite/Dockerfile 2019-09-21 12:58:55.693071151 +0200
|
--- ./git/docker/amd64/sqlite/Dockerfile 2019-12-01 09:42:19.862352658 -0700
|
||||||
+++ Dockerfile 2019-09-21 12:59:48.602484797 +0200
|
+++ Dockerfile 2019-12-01 09:46:27.471287518 -0700
|
||||||
@@ -38,66 +38,58 @@
|
@@ -36,9 +36,9 @@
|
||||||
RUN apt-get update && apt-get install -y \
|
|
||||||
--no-install-recommends \
|
|
||||||
libmariadb-dev \
|
|
||||||
&& rm -rf /var/lib/apt/lists/*
|
|
||||||
|
|
||||||
# Creates a dummy project used to grab dependencies
|
|
||||||
RUN USER=root cargo new --bin app
|
|
||||||
WORKDIR /app
|
WORKDIR /app
|
||||||
|
|
||||||
# Copies over *only* your manifests and build files
|
# Copies over *only* your manifests and build files
|
||||||
@ -20,9 +13,7 @@
|
|||||||
|
|
||||||
# Builds your dependencies and removes the
|
# Builds your dependencies and removes the
|
||||||
# dummy project, except the target folder
|
# dummy project, except the target folder
|
||||||
# This folder contains the compiled dependencies
|
@@ -48,7 +48,7 @@
|
||||||
RUN cargo build --features ${DB} --release
|
|
||||||
RUN find . -not -path "./target*" -delete
|
|
||||||
|
|
||||||
# Copies the complete project
|
# Copies the complete project
|
||||||
# To avoid copying unneeded files, use .dockerignore
|
# To avoid copying unneeded files, use .dockerignore
|
||||||
@ -31,26 +22,14 @@
|
|||||||
|
|
||||||
# Make sure that we actually build the project
|
# Make sure that we actually build the project
|
||||||
RUN touch src/main.rs
|
RUN touch src/main.rs
|
||||||
|
@@ -62,34 +62,25 @@
|
||||||
# Builds again, this time it'll just be
|
|
||||||
# your actual source files being built
|
|
||||||
RUN cargo build --features ${DB} --release
|
|
||||||
|
|
||||||
######################## RUNTIME IMAGE ########################
|
|
||||||
# Create a new stage with a minimal image
|
|
||||||
# because we already have a binary built
|
# because we already have a binary built
|
||||||
FROM debian:stretch-slim
|
FROM debian:buster-slim
|
||||||
|
|
||||||
-ENV ROCKET_ENV "staging"
|
-ENV ROCKET_ENV "staging"
|
||||||
-ENV ROCKET_PORT=80
|
-ENV ROCKET_PORT=80
|
||||||
-ENV ROCKET_WORKERS=10
|
-ENV ROCKET_WORKERS=10
|
||||||
+# Create package directory
|
-
|
||||||
+RUN mkdir -p /bitwarden_package/DEBIAN
|
|
||||||
+RUN mkdir -p /bitwarden_package/usr/local/bin
|
|
||||||
+RUN mkdir -p /bitwarden_package/usr/lib/systemd/system
|
|
||||||
+RUN mkdir -p /bitwarden_package/etc/bitwarden_rs
|
|
||||||
+RUN mkdir -p /bitwarden_package/usr/share/bitwarden_rs
|
|
||||||
|
|
||||||
-# Install needed libraries
|
-# Install needed libraries
|
||||||
-RUN apt-get update && apt-get install -y \
|
-RUN apt-get update && apt-get install -y \
|
||||||
- --no-install-recommends \
|
- --no-install-recommends \
|
||||||
@ -64,6 +43,13 @@
|
|||||||
-VOLUME /data
|
-VOLUME /data
|
||||||
-EXPOSE 80
|
-EXPOSE 80
|
||||||
-EXPOSE 3012
|
-EXPOSE 3012
|
||||||
|
+# Create package directory
|
||||||
|
+RUN mkdir -p /bitwarden_package/DEBIAN
|
||||||
|
+RUN mkdir -p /bitwarden_package/usr/local/bin
|
||||||
|
+RUN mkdir -p /bitwarden_package/usr/lib/systemd/system
|
||||||
|
+RUN mkdir -p /bitwarden_package/etc/bitwarden_rs
|
||||||
|
+RUN mkdir -p /bitwarden_package/usr/share/bitwarden_rs
|
||||||
|
+
|
||||||
+WORKDIR /bitwarden_package
|
+WORKDIR /bitwarden_package
|
||||||
|
|
||||||
# Copies the files from the context (Rocket.toml file and web-vault)
|
# Copies the files from the context (Rocket.toml file and web-vault)
|
||||||
@ -85,6 +71,7 @@
|
|||||||
+COPY --from=build app/target/release/bitwarden_rs /bitwarden_package/usr/local/bin
|
+COPY --from=build app/target/release/bitwarden_rs /bitwarden_package/usr/local/bin
|
||||||
|
|
||||||
-# Configures the startup!
|
-# Configures the startup!
|
||||||
-CMD ["./bitwarden_rs"]
|
-WORKDIR /
|
||||||
|
-CMD ["/bitwarden_rs"]
|
||||||
+# Create the package
|
+# Create the package
|
||||||
+RUN dpkg-deb --build . bitwarden-rs.deb
|
+RUN dpkg-deb --build . bitwarden-rs.deb
|
||||||
|
2
debian/control
vendored
2
debian/control
vendored
@ -2,6 +2,6 @@ Package: bitwarden-rs
|
|||||||
Architecture: amd64
|
Architecture: amd64
|
||||||
Maintainer: Greizgh <greizgh+bitwardenrs@ephax.org>
|
Maintainer: Greizgh <greizgh+bitwardenrs@ephax.org>
|
||||||
Priority: optional
|
Priority: optional
|
||||||
Version: 1.11.0-1
|
Version: 1.13.0-1
|
||||||
Description: Unofficial Bitwarden compatible server written in Rust
|
Description: Unofficial Bitwarden compatible server written in Rust
|
||||||
Homepage: https://github.com/greizgh/bitwarden_rs-debian
|
Homepage: https://github.com/greizgh/bitwarden_rs-debian
|
||||||
|
Loading…
Reference in New Issue
Block a user