bump v1.18.0 for arm32v7
This commit is contained in:
parent
0e7004023c
commit
069766d714
|
@ -1,13 +1,6 @@
|
||||||
--- ./git/docker/arm32v7/Dockerfile 2020-10-31 15:04:00.786589801 +0100
|
--- git/docker/arm32v7/Dockerfile 2020-12-29 21:18:53.687097820 +0100
|
||||||
+++ ./Dockerfile 2020-11-06 17:44:35.204501362 +0100
|
+++ Dockerfile.arm 2020-12-29 21:59:53.090210238 +0100
|
||||||
@@ -54,23 +54,23 @@
|
@@ -61,9 +61,9 @@
|
||||||
&& echo 'rustflags = ["-L/usr/lib/arm-linux-gnueabihf"]' >> ~/.cargo/config
|
|
||||||
|
|
||||||
ENV CARGO_HOME "/root/.cargo"
|
|
||||||
ENV USER "root"
|
|
||||||
|
|
||||||
# Creates a dummy project used to grab dependencies
|
|
||||||
RUN USER=root cargo new --bin /app
|
|
||||||
WORKDIR /app
|
WORKDIR /app
|
||||||
|
|
||||||
# Copies over *only* your manifests and build files
|
# Copies over *only* your manifests and build files
|
||||||
|
@ -20,21 +13,7 @@
|
||||||
|
|
||||||
# NOTE: This should be the last apt-get/dpkg for this stage, since after this it will fail because of broken dependencies.
|
# NOTE: This should be the last apt-get/dpkg for this stage, since after this it will fail because of broken dependencies.
|
||||||
# For Diesel-RS migrations_macros to compile with MySQL/MariaDB we need to do some magic.
|
# For Diesel-RS migrations_macros to compile with MySQL/MariaDB we need to do some magic.
|
||||||
# We at least need libmariadb3:amd64 installed for the x86_64 version of libmariadb.so (client)
|
@@ -95,7 +95,7 @@
|
||||||
# We also need the libmariadb-dev-compat:amd64 but it can not be installed together with the :armhf version.
|
|
||||||
# What we can do is a force install, because nothing important is overlapping each other.
|
|
||||||
RUN apt-get install -y libmariadb3:amd64 && \
|
|
||||||
mkdir -pv /tmp/dpkg && \
|
|
||||||
cd /tmp/dpkg && \
|
|
||||||
apt-get download libmariadb-dev-compat:amd64 && \
|
|
||||||
@@ -90,64 +90,45 @@
|
|
||||||
RUN rustup target add armv7-unknown-linux-gnueabihf
|
|
||||||
|
|
||||||
# Builds your dependencies and removes the
|
|
||||||
# dummy project, except the target folder
|
|
||||||
# This folder contains the compiled dependencies
|
|
||||||
RUN cargo build --features ${DB} --release --target=armv7-unknown-linux-gnueabihf
|
|
||||||
RUN find . -not -path "./target*" -delete
|
|
||||||
|
|
||||||
# Copies the complete project
|
# Copies the complete project
|
||||||
# To avoid copying unneeded files, use .dockerignore
|
# To avoid copying unneeded files, use .dockerignore
|
||||||
|
@ -43,17 +22,12 @@
|
||||||
|
|
||||||
# Make sure that we actually build the project
|
# Make sure that we actually build the project
|
||||||
RUN touch src/main.rs
|
RUN touch src/main.rs
|
||||||
|
@@ -107,45 +107,24 @@
|
||||||
# Builds again, this time it'll just be
|
|
||||||
# your actual source files being built
|
|
||||||
RUN cargo build --features ${DB} --release --target=armv7-unknown-linux-gnueabihf
|
|
||||||
|
|
||||||
######################## RUNTIME IMAGE ########################
|
######################## RUNTIME IMAGE ########################
|
||||||
# Create a new stage with a minimal image
|
# Create a new stage with a minimal image
|
||||||
# because we already have a binary built
|
# because we already have a binary built
|
||||||
-FROM balenalib/armv7hf-debian:buster
|
-FROM balenalib/armv7hf-debian:buster
|
||||||
+FROM debian:buster-slim
|
-
|
||||||
|
|
||||||
-ENV ROCKET_ENV "staging"
|
-ENV ROCKET_ENV "staging"
|
||||||
-ENV ROCKET_PORT=80
|
-ENV ROCKET_PORT=80
|
||||||
-ENV ROCKET_WORKERS=10
|
-ENV ROCKET_WORKERS=10
|
||||||
|
@ -84,24 +58,22 @@
|
||||||
-COPY Rocket.toml .
|
-COPY Rocket.toml .
|
||||||
-COPY --from=vault /web-vault ./web-vault
|
-COPY --from=vault /web-vault ./web-vault
|
||||||
-COPY --from=build /app/target/armv7-unknown-linux-gnueabihf/release/bitwarden_rs .
|
-COPY --from=build /app/target/armv7-unknown-linux-gnueabihf/release/bitwarden_rs .
|
||||||
-
|
+FROM debian:buster-slim
|
||||||
|
|
||||||
-COPY docker/healthcheck.sh /healthcheck.sh
|
-COPY docker/healthcheck.sh /healthcheck.sh
|
||||||
-COPY docker/start.sh /start.sh
|
-COPY docker/start.sh /start.sh
|
||||||
-
|
|
||||||
-HEALTHCHECK --interval=60s --timeout=10s CMD ["/healthcheck.sh"]
|
|
||||||
-
|
|
||||||
-# Configures the startup!
|
|
||||||
-WORKDIR /
|
|
||||||
-CMD ["/start.sh"]
|
|
||||||
+# Create package directory
|
|
||||||
+RUN mkdir -p /bitwarden_package/DEBIAN
|
+RUN mkdir -p /bitwarden_package/DEBIAN
|
||||||
+RUN mkdir -p /bitwarden_package/usr/local/bin
|
+RUN mkdir -p /bitwarden_package/usr/local/bin
|
||||||
+RUN mkdir -p /bitwarden_package/usr/lib/systemd/system
|
+RUN mkdir -p /bitwarden_package/usr/lib/systemd/system
|
||||||
+RUN mkdir -p /bitwarden_package/etc/bitwarden_rs
|
+RUN mkdir -p /bitwarden_package/etc/bitwarden_rs
|
||||||
+RUN mkdir -p /bitwarden_package/usr/share/bitwarden_rs
|
+RUN mkdir -p /bitwarden_package/usr/share/bitwarden_rs
|
||||||
+
|
|
||||||
|
-HEALTHCHECK --interval=60s --timeout=10s CMD ["/healthcheck.sh"]
|
||||||
+WORKDIR /bitwarden_package
|
+WORKDIR /bitwarden_package
|
||||||
+
|
|
||||||
|
-# Configures the startup!
|
||||||
|
-WORKDIR /
|
||||||
|
-CMD ["/start.sh"]
|
||||||
+COPY debian/control /bitwarden_package/DEBIAN/control
|
+COPY debian/control /bitwarden_package/DEBIAN/control
|
||||||
+COPY debian/postinst /bitwarden_package/DEBIAN/postinst
|
+COPY debian/postinst /bitwarden_package/DEBIAN/postinst
|
||||||
+COPY debian/conffiles /bitwarden_package/DEBIAN/conffiles
|
+COPY debian/conffiles /bitwarden_package/DEBIAN/conffiles
|
||||||
|
@ -110,7 +82,6 @@
|
||||||
+COPY debian/bitwarden_rs.service /bitwarden_package/usr/lib/systemd/system
|
+COPY debian/bitwarden_rs.service /bitwarden_package/usr/lib/systemd/system
|
||||||
+COPY --from=vault /web-vault /bitwarden_package/usr/share/bitwarden_rs/web-vault
|
+COPY --from=vault /web-vault /bitwarden_package/usr/share/bitwarden_rs/web-vault
|
||||||
+COPY --from=build app/target/armv7-unknown-linux-gnueabihf/release/bitwarden_rs /bitwarden_package/usr/local/bin
|
+COPY --from=build app/target/armv7-unknown-linux-gnueabihf/release/bitwarden_rs /bitwarden_package/usr/local/bin
|
||||||
+
|
|
||||||
+# Create the package
|
+# Create the package
|
||||||
+RUN dpkg-deb --build . bitwarden-rs.deb
|
+RUN dpkg-deb --build . bitwarden-rs.deb
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue