26 lines
480 B
Makefile
26 lines
480 B
Makefile
#!/usr/bin/make -f
|
|
# -*- makefile -*-
|
|
|
|
# Uncomment this to turn on verbose mode.
|
|
export DH_VERBOSE=1
|
|
|
|
HYDRA_VERSION := v1.10.6
|
|
|
|
%:
|
|
dh $@ --with systemd
|
|
|
|
override_dh_auto_build: $(GOPATH)
|
|
./script/install.sh -b bin -d $(HYDRA_VERSION)
|
|
|
|
override_dh_auto_install:
|
|
mkdir -p debian/hydra/usr/bin
|
|
mkdir -p debian/hydra/etc/hydra
|
|
|
|
cp bin/hydra debian/hydra/usr/bin/hydra
|
|
cp conf/hydra.yml debian/hydra/etc/hydra
|
|
|
|
install -d debian/hydra
|
|
|
|
override_dh_strip:
|
|
|
|
override_dh_auto_test: |